Chrysler 300M Enthusiasts Club
  • Problems and Complaints

  • Repair Questions and Answers.
Membership Banner

Repair Questions and Answers.

Moderator: Moderators

Forum Statistics Last post
FOTKI
by FIREM  -   - in: Official Announcements
16 Replies 
 60914 Views
 by FIREM
 
Important: Forum Best Practices For All
by BOD  -   - in: Official Announcements
0 Replies 
 51502 Views
 by BOD
 
Terms of Service
by BOD  -   - in: Official Announcements
2 Replies 
 55824 Views
 by BOD
 
Forum Statistics Last post
Long Cranks Before Starting
by MY300M  - 
109 Replies 
 53319 Views
 by Chanley
 
*Gas tank straps--check yours if over 7 yrs old*
by EasyRider300M  - 
43 Replies 
 22303 Views
 by beespecial
 
Steering rack check?
by JohnnyP  - 
34 Replies 
 722 Views
 by LUNAT1C
 
Transmission shift problem
by XboXC  - 
3 Replies 
 106 Views
 by TrepKing95
 
10 Replies 
 239 Views
 by Nickertrip
 
Missing 1 of these from under intake
by Sirdigbychknczr  - 
9 Replies 
 257 Views
 by M-Pressive
 
Need some help figuring out what I need...
by AndrewLane  - 
6 Replies 
 191 Views
 by 135sohc
 
Special half shaft diameter.
by rustybronco  - 
16 Replies 
 269 Views
 by rustybronco
 
Rocker arm tick causing other issues?
by OttoOlin  - 
2 Replies 
 84 Views
 by FIREM
 
Clock Spring fitment for 2000 300M
by Pebble  - 
1 Replies 
 119 Views
 by FIREM
 
Antifreeze leak after shutting off car
by Nickertrip  - 
16 Replies 
 867 Views
 by rustybronco
 
I am Stumped.....
by M-Pressive  - 
16 Replies 
 1296 Views
 by Sneke_Eyez
 
Steering Rack Situation
by born2pdl  - 
28 Replies 
 1017 Views
 by LUNAT1C
 
Melted underhood fuse box
by Nickertrip  - 
1 Replies 
 105 Views
 by FIREM
 
RB1 Disc Error
by Countachqv  - 
3 Replies 
 119 Views
 by FIREM
 
Oil pressure light
by Chanley  - 
5 Replies 
 131 Views
 by FIREM
 
16 Replies 
 425 Views
 by In-trepid
 
Running Rough, P0404 code
by timmycharger  - 
9 Replies 
 313 Views
 by LUNAT1C
 
Water, passenger side.
by KxWarrior  - 
21 Replies 
 494 Views
 by TrepKing95
 
Lights, no codes
by Rtmmn87  - 
4 Replies 
 186 Views
 by Rtmmn87
 
Having Trouble Starting
by Sharper  - 
2 Replies 
 125 Views
 by LUNAT1C
 
p 0340
by brewsj  - 
11 Replies 
 2027 Views
 by TrepKing95
 
17 Replies 
 851 Views
 by FIREM
 
PCV hose replacement?
by LUNAT1C  - 
29 Replies 
 2621 Views
 by 135sohc
 
Very High RPM at start up
by Ercouper  - 
3 Replies 
 178 Views
 by LUNAT1C
 
‘04 300M randomly no crank
by ANDREW0452  - 
4 Replies 
 250 Views
 by ANDREW0452
 
2003 transmission problems
by Nick82  - 
13 Replies 
 675 Views
 by Nick82
 
Shaking?
by RicanCrazy  - 
35 Replies 
 1147 Views
 by ANDREWT360
 
'99 LHS Timing Belt do I or not?
by GoofySenior  - 
11 Replies 
 1064 Views
 by LUNAT1C
 
6 Replies 
 355 Views
 by FIREM
 
Gas and brake pedal hard!
by CTexter  - 
3 Replies 
 494 Views
 by FIREM
 
Tensioner in rock auto kit wrong?
by First Lady  - 
4 Replies 
 770 Views
 by First Lady
 
Coolant won’t drain
by Nick82  - 
7 Replies 
 571 Views
 by LUNAT1C
 
Fuel Tank Strap Disaster
by Micah13  - 
2 Replies 
 310 Views
 by LUNAT1C
 
Struts never ending saga
by Countachqv  - 
5 Replies 
 347 Views
 by cin993
 
27 Replies 
 2955 Views
 by Phoenix
 
AC Issues - Help Me Diagnose
by M-Pressive  - 
10 Replies 
 1569 Views
 by LUNAT1C
 
1998 lxi concorde blower motor
by maddog56  - 
8 Replies 
 795 Views
 by maddog56
 
Key Stuck in Ignition
by StoneWhiteWolf  - 
10 Replies 
 2828 Views
 by FIREM
 
Sounds like an air leak
by JohnnyP  - 
4 Replies 
 362 Views
 by JohnnyP
 
Muffler Ground wire dangling, where to put it back?
by CTexter  - 
7 Replies 
 446 Views
 by Sneke_Eyez
 
Burning smell, misfiring, confusing codes
by CTexter  - 
12 Replies 
 1152 Views
 by LUNAT1C
 
300M 2.7 Electronics error? PLS help
by Hagees  - 
1 Replies 
 834 Views
 by FIREM
 
Car won't move
by Travi510  - 
7 Replies 
 3637 Views
 by FIREM
 
6 Replies 
 447 Views
 by LUNAT1C
 
19 Replies 
 2207 Views
 by 1996LHS
 
Quick questions
by OttoOlin  - 
3 Replies 
 386 Views
 by OttoOlin
 
Rear Main Seal?
by M-Pressive  - 
4 Replies 
 1498 Views
 by FIREM
 
slow motion Transaxle leak
by Countachqv  - 
6 Replies 
 636 Views
 by FIREM
 
Transmission Output Speed Sensor Why's
by Ercouper  - 
6 Replies 
 436 Views
 by FIREM
 
  • 1
  • 2
  • 3
  • 4
  • 5
  • 106