Chrysler 300M Enthusiasts Club
  • Problems and Complaints

  • Repair Questions and Answers.
Membership Banner

Repair Questions and Answers.

Moderator: Moderators

Forum Statistics Last post
FOTKI
by FIREM  -   - in: Official Announcements
16 Replies 
 59928 Views
 by FIREM
 
Important: Forum Best Practices For All
by BOD  -   - in: Official Announcements
0 Replies 
 50923 Views
 by BOD
 
Terms of Service
by BOD  -   - in: Official Announcements
2 Replies 
 55239 Views
 by BOD
 
Forum Statistics Last post
Long Cranks Before Starting
by MY300M  - 
108 Replies 
 52124 Views
 by superblackbird00
 
*Gas tank straps--check yours if over 7 yrs old*
by EasyRider300M  - 
43 Replies 
 21867 Views
 by beespecial
 
Gas and brake pedal hard!
by CTexter  - 
3 Replies 
 98 Views
 by FIREM
 
Tensioner in rock auto kit wrong?
by First Lady  - 
4 Replies 
 199 Views
 by First Lady
 
'99 LHS Timing Belt do I or not?
by GoofySenior  - 
5 Replies 
 227 Views
 by In-trepid
 
Coolant won’t drain
by Nick82  - 
7 Replies 
 220 Views
 by LUNAT1C
 
Fuel Tank Strap Disaster
by Micah13  - 
2 Replies 
 132 Views
 by LUNAT1C
 
Struts never ending saga
by Countachqv  - 
5 Replies 
 149 Views
 by cin993
 
27 Replies 
 2499 Views
 by Phoenix
 
PCV hose replacement?
by LUNAT1C  - 
27 Replies 
 1815 Views
 by FIREM
 
2003 transmission problems
by Nick82  - 
7 Replies 
 258 Views
 by EasyRider300M
 
AC Issues - Help Me Diagnose
by M-Pressive  - 
10 Replies 
 1169 Views
 by LUNAT1C
 
1998 lxi concorde blower motor
by maddog56  - 
8 Replies 
 564 Views
 by maddog56
 
Key Stuck in Ignition
by StoneWhiteWolf  - 
10 Replies 
 2540 Views
 by FIREM
 
Sounds like an air leak
by JohnnyP  - 
4 Replies 
 213 Views
 by JohnnyP
 
Muffler Ground wire dangling, where to put it back?
by CTexter  - 
7 Replies 
 283 Views
 by Sneke_Eyez
 
Burning smell, misfiring, confusing codes
by CTexter  - 
12 Replies 
 932 Views
 by LUNAT1C
 
300M 2.7 Electronics error? PLS help
by Hagees  - 
1 Replies 
 741 Views
 by FIREM
 
Car won't move
by Travi510  - 
7 Replies 
 3521 Views
 by FIREM
 
6 Replies 
 293 Views
 by LUNAT1C
 
19 Replies 
 1971 Views
 by 1996LHS
 
Quick questions
by OttoOlin  - 
3 Replies 
 287 Views
 by OttoOlin
 
Rear Main Seal?
by M-Pressive  - 
4 Replies 
 1329 Views
 by FIREM
 
slow motion Transaxle leak
by Countachqv  - 
6 Replies 
 521 Views
 by FIREM
 
Transmission Output Speed Sensor Why's
by Ercouper  - 
6 Replies 
 314 Views
 by FIREM
 
Need help identifying engine harness wire
by LUNAT1C  - 
3 Replies 
 299 Views
 by FIREM
 
broken seat back
by Slick300M  - 
7 Replies 
 326 Views
 by TrepKing95
 
2 Replies 
 240 Views
 by TrepKing95
 
1999 300m - Missing Vacuum Hose
by noco  - 
2 Replies 
 222 Views
 by noco
 
No Bus Problems, No gauges
by Johncsavage3  - 
4 Replies 
 348 Views
 by LUNAT1C
 
'High Carbon Brake Rotors"
by cin993  - 
5 Replies 
 548 Views
 by cin993
 
6 Replies 
 531 Views
 by In-trepid
 
Transmission hard shift
by cin993  - 
1 Replies 
 282 Views
 by FIREM
 
Rocker Arm Tick
by In-trepid  - 
12 Replies 
 1493 Views
 by turboapc
 
PCM - 2003 Chrysler 300m Special
by e-peezy  - 
11 Replies 
 626 Views
 by e-peezy
 
Timing belts and cam gear alignment
by MoPar~Guy  - 
5 Replies 
 465 Views
 by Countachqv
 
no oil pressure warning light
by turboapc  - 
4 Replies 
 362 Views
 by FIREM
 
Brake master cylinder faulty?
by OttoOlin  - 
10 Replies 
 720 Views
 by turboapc
 
Shifter cable for a 2002 Chrysler 300M
by jrouter300M  - 
7 Replies 
 826 Views
 by LUNAT1C
 
Best method to prevent cam from snapping over?
by LUNAT1C  - 
11 Replies 
 1257 Views
 by cin993
 
'99 LHS Brake fitting leak
by GoofySenior  - 
6 Replies 
 634 Views
 by GoofySenior
 
Positive Battery Cable & Fusible Link Replacement
by mrnrod  - 
1 Replies 
 524 Views
 by FIREM
 
Cable 5114093AA
by Dschwartz  - 
6 Replies 
 844 Views
 by FIREM
 
16 Replies 
 3550 Views
 by redmax
 
Time for the crusher?
by user97  - 
12 Replies 
 810 Views
 by FIREM
 
Solving Oil Leak
by monte4  - 
15 Replies 
 727 Views
 by MoPar~Guy
 
Trunk harness typical issues, confirming fault?
by LUNAT1C  - 
6 Replies 
 851 Views
 by MoPar~Guy
 
One Touch Down Not Working
by Herb59  - 
3 Replies 
 542 Views
 by FIREM
 
A/M Electroluminescent module
by rustybronco  - 
7 Replies 
 845 Views
 by rustybronco
 
Stumbling When Starting
by M-Pressive  - 
11 Replies 
 608 Views
 by EasyRider300M
 
  • 1
  • 2
  • 3
  • 4
  • 5
  • 105