Chrysler 300M Enthusiasts Club
  • Close Button On Sunroof Switch

  • Repair Questions and Answers.
Ocean City 2019 Banner

Membership Banner

Repair Questions and Answers.

Moderator: Moderators

User avatar
 #332372  by DarkKnight1
 May 23rd, 2014, 11:25 pm
The close button on my sunroof switch doesn't work. Open and vent both work normally, and I can close it using the Open/Vent button. But when I push close, nothing happens. No noise. No movement. Nothing. I swapped out my gray EVIC for a black one, using a different switch, and there was no change, so unless both switches are bad, that's not the problem. Doesn't seem to be the motor either, since it works and there is no noise. Any suggestions???
 #332380  by PurpleCat
 May 24th, 2014, 1:17 pm
My close switch required so much pressure, nearly broke my thumb. Try squirting a bunch of WD-40 into the switch. Hold a rag around it to contain the mess. WD-40 is a non-connector. My close switch works fine now.

EDIT: "non-conductor" :oops:
User avatar
 #332383  by cougar214
 May 24th, 2014, 1:51 pm
Have you disconnected your battery for anything lately? I ask because I did for some work I was doing on mine and then my damn close button wouldn't work either. After pressing it like a mad man for a few minutes it decided to work again. Lon makes a good point as well. Switches tend to corrode over time and not make a good connection. Cleaning it may be all you need to do. But with you changing it out for another one and getting the same result, It could be a wiring problem up there. Best I can say to that is get yourself a test light to see if current is flowing through the wires going to that switch. I'm not sure were the wires are directed up there so I can't help with that. Most likely they are going over the drivers side to the pillar and down to the kick panel or fuse panel. And I don't know if there are any "fusable links" in those wires anywhere that could have popped on you.

EDIT: All Data says to remove your drivers side upper quarter panel, leaving the seat belt attached, and inspect the wiring harness, connector, and ground strap. Apparently, this is a common issue in your M.
User avatar
 #333308  by DarkKnight1
 June 10th, 2014, 9:42 pm
The upper quarter panel? On the exterior of the car? Or one of the pillar trim pieces on the drivers side? I did disconnect the battery and that seemed to help it operate more smoothly, but still NOTHING from the close button. Took the switch apart and used WD40, but no effect either. What pieces do I need to remove and what do I check to serif there is a short or other issue?
User avatar
 #333312  by M-Pressive
 June 10th, 2014, 10:16 pm
Interior of the car. Behind the rear seat. It is a triangular piece and the harness is behind it. I had a ground problem back there and wiggling the plug fixed it.
User avatar
 #333315  by DarkKnight1
 June 10th, 2014, 10:37 pm
Thanks for the assist! That just became tomorrow's project. Today's was the WD 40 and fixing the P0582 and P0586 codes. The wiring harness was unplugged from the servo. No doubt a remnant from the Hell On Earth - Broken Timing Belt & Bent Valves Tour! Sheez!!!!!
User avatar
 #333343  by DarkKnight1
 June 11th, 2014, 8:03 pm
ARGH!!! No dice on checking the connections on the drivers side pillar. I unplugged the one plug that was there and cleaned it w/ WD40. So what's next to try? I'm really hoping it is not the motor. With the timing issue, that causes me some concern. I may just have to deal with the finicky Open/Vent switch.
 #333344  by piperdog
 June 11th, 2014, 8:16 pm
I hadn't operated my sunroof since last summer. When I opened it last week it wouldn't close. I thought I was in for a big investigation (like you). However, I simply pushed much more firmly on the switch and it then worked and closed the sunroof. Similar experience to that of PurpleCat. I conclude that the switch contact can with age become corroded/tarnished/damaged such that a closed contact is difficult to make. While I should dismantle and clean the switch, for the time being I'm simply going to push harder.
User avatar
 #333355  by Ratherbedriving
 June 12th, 2014, 10:24 am
Same thing happened to me last year. I thought something major was wrong and I found out it just required a TON of pressure to get close to work. I bought a new cover for the EVIC from another member which included the switch. The layout is different to. My old switch had a simply arrow rocker switch with forward and back with a circle button in the middle for the vent function. The one I swapped to has a dedicated close button with a open/vent button that rocks left to right. It did require splicing the wires due to a different pin out but the new switch worked like a champ.

Anyway, I guess what I was getting to is if the one type of switch is problematic for others and that is what you tried replacing it with, then maybe its possible the replacement switch is also bad?
 #333367  by ddurr92
 June 12th, 2014, 6:11 pm
I replaced the switch on mine thanks to kieth.. But mine didn't close the other day.. Like something was blocking it..but shortly after it worked again.. Try a new switch
User avatar
 #333374  by DarkKnight1
 June 12th, 2014, 8:06 pm
Anybody have a black switch for sale? I switched my gray one out for a black one. Or a good online source to order one?
 #380657  by ThisIsWhatWeDo
 September 10th, 2019, 10:22 pm
Resurrecting this thread... I am in need of a new sunroof control switch myself. Has anyone found a known good source they can recommend?

My findings: MoPar itself is of course out (P/N = 5JL921L2AA), which is too bad since it's list price is actually reasonable. Other sites indicate they have that P/N (but do they?), and I see there is a BWD P/N S51918 alternative... Has anyone actually tried to buy any of these within the past year or so?

If you have disassembled this particular switch, you will discover that they simply go bad, primarily due to aging... the conductive glazing that's coating the rubber membrane in specific locations (to cause a circuit to be completed when the button is pushed, in each of three different button articulations for each of the desired sunroof control commands) deteriorates with the extreme environmental cycles that a car sees. If anyone knows of a trick to re-apply a conductive coating to the rubber membrane, the switch could be rebuilt. I tried using aluminum foil as a substitute, but I couldn't get it to actually adhere.

Thanks in advance!
 #380661  by dcsally97
 September 11th, 2019, 8:11 am
I picked up an EVIC from a salvage yard for $5 and wired the older style switch to my '04 harness. The '04 inline switch is not real good. I prefer the older style with the separate close button. Also, when I did the swap, I used the guts from my EVIC so everything worked properly.
User avatar
 #380682  by Sneke_Eyez
 September 12th, 2019, 1:35 pm
Like Doug, I converted my 04 Special to the 99-02 style switch, after replacing the switch approximately 5 times with switches from the junkyard that would then break.

The older style switch is significantly better and I am convinced it will last.
User avatar
 #380688  by LUNAT1C
 September 12th, 2019, 4:07 pm
Sounds like that's the key, if your switch is the newer style. I've only ever had one issue with the switch in my 02, the older style, and it seemed to resolve itself right away. Assuming it was a fluke problem with my electrical system from the battery draining. I might have some spare EVIC covers with the older style switch in a bin in the basement.