Chrysler 300M Enthusiasts Club
  • Oil Light Flicker

  • Repair Questions and Answers.
Carlisle Chrysler Nationals

Membership Banner

Repair Questions and Answers.

Moderator: Moderators

User avatar
 #388657  by ryogenic
 
1998 Concorde 3.2L, the symptom is the oil light flickers AT IDLE after the car is warm, but only after it's driven. It will not flicker after a cold start and 1 hour of idle, but start driving and then come to a stop, and it will start flickering at idle constantly until cooling and repeating the process. It doesn't flicker when the car is moving.

Replaced the OIL PUMP, replaced the OIL PRESSURE SENSOR, deleted the OIL COOLER / LINES.

Oil light still flickers.

Is my main bearing spun, and is it time for a new engine? Thanks for your time!
User avatar
 #388659  by FIREM
 
Connect a real gauge to check the pressure. Minimum 5psi hot idle, 35 +++ above 1500 rpm, Can be as high as 100.
User avatar
 #390827  by ryogenic
 
Hey FIREM just thought I'd give you an update since you were so kind to reply before :) so what I ended up doing is giving her the old Italian tune-up. This car sat for at least a couple years after being abused, and I got it for cheap because a grenade went off in the transmission. I put in a new gearbox and flex plate (I have access to a lift), and then what I did was keep it really happy in terms of transmission oil, engine oil, coolant, and temperature, and I drove it in such a way to give it really smooth revs and shifting at the high end of RPMs, and the 3.2 performs beautifully, and I changed the oil quite a few times to try and flush any old cruddy oil out from the previous owner's misdeeds. I also went to ACE Hardware and bought I think a 5/8" male flare fitting to plug the engine oil cooler line and just screwed the sensor directly into the block, which means my oil cooler is completely passive and / or non-functional. The reason I did this is because part number 5014313AA was leaking, so I deleted it. At this point I was still getting a flickering oil light, and forgive me for not realizing or mentioning this, but the RPMs were dipping at the same time. Truly a critical error on my part; the oil light is going to come on when the idle is so rough that the engine almost dies. I am a novice mechanic to say the least, but I do have an older mechanic friend who helps me from time to time so I'm learning.

The rough idle persists to this day however it has come around enough that the RPMs don't dip enough to illuminate the dash light. Believe it or not I haven't sprayed a lick of cleaner in the throttle body, but now that I understand what's happening, I will get around to it eventually. The stock radiator end tank blew a leak this Monday, so I was up until 1:00 AM that night putting in a new rad from Oreilly's 8) They also have some nice pre formed upper and lower hoses that I was happy to find in stock the same day it sprung a leak because I got home from work on Monday by pouring in what was left of my water bottle which just so happened to bring the overflow to the minimum level, and I was able to make it to work on time the next day on the new rad. Considering that the end tank on the radiator had failed, who knows what kind of problems that could have caused, because it runs better now. I do love my weird 300M, that's what I call it, because it looks exactly like a 300M but just a little weird. I will get it clean and maybe some hub caps and then you can see it. 8)
User avatar
 #390829  by FIREM
 
Good to hear your car is still up and running. Sounds like your oil light issue is directly related to the rough idle. Throttle body cleaning would most likely solve the problems on the cheap.
How old are the spark plugs and air cleaner, all part of the equation also.
Radiator tanks are somewhat rather common issues as our cars age, be sure to get the proper mix of GO 5 coolant in there ASAP.