Chrysler 300M Enthusiasts Club
  • Automatic Temperature Control (ATC) display help..advice...suggestions

  • Repair Questions and Answers.
25th Anniversary LH Platform Celebration

Membership Banner

Repair Questions and Answers.

Moderator: Moderators

 #367196  by cin993
 May 12th, 2017, 2:09 pm
Few times a year my ATC display would black out. The heat and AC buttons would all work but the display itself would just be dark. If I bumped the ATC display with the palm of my hand the display would light back up.

So i tried to fix this pita.

I took it apart to solder the ATC resistors for small cracks...a common issue.

Now when I put it all back together the display is always dark but the heat and AC do work.
Resoldered a second time and still the display is all dark.

Seems like many have fixed this successfully. What do you think I should try? Any tips? Thanks all.

Also, the 17R8 resistor that's upside down in the first pic came off the first time I put some heat on the joint as I pulled the soldering gun away
You do not have the required permissions to view the files attached to this post.
 #367200  by JTROANOKE
 May 12th, 2017, 4:46 pm
Did you say soldering gun? Typical soldering guns run a little hot for pc board wiring. A pencil iron of 30watts or so is about max. My gun is a 100/135 and is way hot for that kind of board. If your gun is like mine I am guessing that you may have damaged the PCB or a resistor.
300maximilien liked this
 #367240  by cin993
 May 15th, 2017, 1:53 pm
She's back! now when i touch her buttons she lights up fine!

With some time this weekend i removed the pita resistor and all old solder from the board. Then i carefully resoldered the resistor and boom, she's on again.

fyi- these resistors are very, very small...this is really delicate work. so have a gentle touch, and a little patience
You do not have the required permissions to view the files attached to this post.
M-Pressive liked this