Chrysler 300M Enthusiasts Club
  • What did you do to your car today?

  • General Discussions about the 300M and other LHs
Ocean City 2019 Banner

Membership Banner

General Discussions about the 300M and other LHs

Moderator: Moderators

User avatar
 #391426  by First Lady
 
Yesterday was kinda a bust as the 100% humidity totally messed with me trying to wax the blue car. Complete nightmare!!!!

Keith started to clean my wheels, wells, and brakes.

This morning tried again with the wax. No go with the new stuff so resorted back to the old. Have one more coat to do this afternoon.

Mobile wheel mounting guy came to join the fun this morning and mounted John’s new wheels. AMAZING!!!!!!!! They look so good and I’m so happy to have done this for him!!!! Can’t wait to get them on the car and take some pictures!!!

Quick shower for an interview and then will be back in the garage til bed!!!
User avatar
 #391428  by LUNAT1C
 
Yikes, you mentioned last night the humidity was making life hard, I didn't imagine 100%! I let my car sit with coat 2 for a couple hours and it still didn't fully dry, I don't think we had more than 50%.

Can't wait to see Beespecial done! Its fog lights are stashed in my trunk and ready to go.

Last night I did some things here and there. Polished the drivers side door jambs, cleaned under the upper weather strip and behind the lower, applied Xpress spray wax. I took out the OEM front mats and hit them with the hose, APC, drill brush, Bissel carpet cleaner. They're still in the garage drying... I also installed the refreshed striker hardware on the driver's side. PSA: If you plan to mess with your door striker, put masking tape on the body around the strike plate. This will mark the location and make it MUCH easier to realign the door. I did not do this on the rear door and paid the price, it still needs some adjustment. I did it on the front door and was golden on the first try.

I also put my new OEM headlights (NOS) into my makeshift oven (large plastic tub with hole cut big enough to jam a heat gun into, and cardboard divider to deflect direct heat on the lamp, thermometer to monitor temp) and opened them up. Used a grinder on my dremel to open up the HB spots a bit and help sink the units, and a hole saw bit on my drill to open up the LB holes. Plan to open them up some more and use two other hole saw bits to make mounting plates, which should be enough for mounting all four units. Drill holes for wiring to pass through, remove chrome, paint black, then I can install the units and aim them. Might be able to do much of that tonight, but I have no expectation of having these lights at Carlisle. Would still need to trim the shrouds and epoxy to the units, seal and install on the car with new LED controllers, and tomorrow is my one day a week I'm expected in the office. Still need to pack as well. Really hoping I can get away with bringing *less*.
User avatar
 #391430  by In-trepid
 
Got the car packed. way too much stuff like a jack, jack stands, heavy duty impact wrench, a set of headlights to sell if anyone is interested, and a couple of parts for some attendees. The car still needs a little interior cleaning, but the outside, wheels, and wheel wells are clean. It will give me something to do at the show field. Kyle and I leave in the morning (Wednesday) for our customary trip to the last exit in Ohio by tomorrow night leaving us about four hours of travel on Thursday.
User avatar
 #391431  by M-Pressive
 
In-trepid wrote:Got the car packed. way too much stuff like a jack, jack stands, heavy duty impact wrench, a set of headlights to sell if anyone is interested, and a couple of parts for some attendees. The car still needs a little interior cleaning, but the outside, wheels, and wheel wells are clean. It will give me something to do at the show field. Kyle and I leave in the morning (Wednesday) for our customary trip to the last exit in Ohio by tomorrow night leaving us about four hours of travel on Thursday.

See you Thursday!

Safe travels
User avatar
 #391436  by FIREM
 
It is amazing the impact humidity has on polish and detailing products.
Image
Past week of cleaning and detailing has been great. Had to stop one afternoon when it got as hot as 76 drgrees in the shop. :lol:
See you all Thursday afternoon.
Safe Travels Everyone
User avatar
 #391440  by LUNAT1C
 
FIREM wrote: July 13th, 2022, 7:43 am It is amazing the impact humidity has on polish and detailing products.
Image
Past week of cleaning and detailing has been great. Had to stop one afternoon when it got as hot as 76 drgrees in the shop. :lol:
See you all Thursday afternoon.
Safe Travels Everyone
That's typically as warm as my shop gets... won't be quite that warm 6 months from now though. :roll:
User avatar
 #391495  by LUNAT1C
 
Carlisle has led to a few things... during the trip I noticed that low speed thumping noise over bumps while turning was not just a "sitting too long" phenomenon. Planning to replace the outer tie rod ends and inner bushings since mine are original and hope that takes care of it at the same time (outer joint boots are looking worse for wear). Then have the alignment done and evacuate the AC so I can replace the condenser.

If that doesn't do it, I just ordered a set of front OEM strut mounts and a pair of OEM bearing assemblies. I will plan sometime later on to remove the front struts, disassemble, and repack the original bearings with fresh EP chassis grease. If things look to be too worn out, I will replace with the NOS OEM parts, but I'm hoping to keep them "in stock" for a while and get lots more miles from the set that was put in 45,000 miles/11 years ago, when it's time for new struts as well. Car is at 143k now and I'd like to get it to 180k before needing that. That'll be 7 years at this point, when it's due for a timing belt again.

Current mounts are Mopar units installed when the front struts were replaced (OEM Special units) Spring 2011 at 97k. I thought at that time the bearing assemblies were part of the mounts, but it sounds like that's near the time Chrysler separated them, so it's possible what I have now is the original 20 year old 143,000 mile bearing assemblies. I may practice removing a strut at the yard and separating with my spring clamps, to see if I can remove the bearing assembly without spilling bearings and teaching the kids in our cul-de-sac fun new words to impress mommy and daddy with...
StealthM, Sneke_Eyez liked this
User avatar
 #391610  by LUNAT1C
 
Took it in to a new-to-me shop in town that came highly regarded by locals, including folks with classic cars, to get a front end alignment and AC evac. After a few hours, they finished the evac and told me when they checked the alignment, it was going to need a 4-wheel and I'd have to come back and drop it for the day. The reason is the rear camber is out of spec. In the back of my head I recall there being something about the rear that was not adjustible and couldn't remember what at the time, but now I know it's the camber and I should expect it to be out of spec. Made an appointment for Thursday and I plan to ask them how they intend to adjust the rear camber when it isn't possible to do with factory lateral links (I have not replaced any of them). They did not have a printout of the current alignment situation (I hadn't asked for it initially, expecting to need only the front), only that everything is about 1 degree out. I believe 1 degree is normal for rear camber. I'll ensure I get a before and after, and would prefer if they showed me how they do it. Either they don't know it can't be adjusted, or they know a trick.

I went in telling them it was recently repainted and asked them to be careful with it. Still saw the tech quickly maneuvering it in the parking lot, but they were surprised how "sharp" it is.
User avatar
 #391611  by FIREM
 
Camber or Inward/Outward Tilt top to bottom can be adjusted MAYBE on the rear of an M.
If you have installed adjustable lateral links both front and rear of the rear spindle then yes.
Originally only the rear link was adjustable so the rear TOE could be set.
Camber is a stability setting that has minimal impact on tire wear*
*( Unless you are "Ricer/Honda" squatted with extreme negative Camber)
If it is less than 1 degree negative I wouldn't worry.
User avatar
 #391617  by In-trepid
 
I have added adjustable front lateral links on the rear suspension. The car was originally out by about 1 degree. Two things I noticed most is the car seems to track a bit straighter (I know this could be more a matter of toe alignment also) and the tire noise is decreased. Does 1 degree make a difference in camber? I think so. I would also guess that the front is either out of spec or close to being so on one side or the other unless you have a "cam" bolt installed in one of the lower strut mounts so that front camber can also be adjusted (this also couldn't be adjusted from the factory). My feeling is that a spec exists for a reason and I try to get my cars to that spec however possible. I do believe though the front camber is more critical than rear camber. Good luck with the guys at the shop! There is no other "secret" way to adjust it.
User avatar
 #391623  by LUNAT1C
 
I haven't done anything in the rear outside of struts, sway bar bushings, links 11 years ago. Factory lateral links and front strut bolts are still there.

Out of curiosity, should I be concerned finding rust "dust" on my passenger front strut around the base of the rod? Mounts and struts were done 11 years/45k ago. The noise I'm getting seems to be from this corner. Factory components still there are the spring, jounce bumper (I think), and bearing (I think). End of August after the NOS bearings I ordered come in, I may get the front struts out and inspect the bearings, repack with EP lithium grease of I can/if needed.

Passenger side (rust particles)
PXL_20220731_002513893.jpg
PXL_20220731_002526229.jpg
Driver side (just dirt)
PXL_20220731_002612599.jpg
PXL_20220731_002620343.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
 #391663  by LUNAT1C
 
Well, this is definitely a shop I will not be using for any future needed work.

Took the car to them Tuesday for front end alignment and AC evac. Evac was done, however they said it would need a 4 wheel alignment because the rear camber was out. That should have been a clue not to return. But I humored then and brought it back yesterday morning to leave for the day. As the day wound down, they texted me and said they couldn't get to it that day. So, the car needlessly sat outside in the rain and sun all day. I told them to park it inside overnight, but I'm sure they didn't bother.

Today rolls around, they said they would do it first thing in the morning. 11:30 am text is "we're pulling another car into the rack now, yours is next". So much for first thing. 4pm comes around, the text is "you're on the rack now should be done shortly!". 5pm text "all specs are now perfect, should be able to pick up at 6 (they close at 6), but the steering wheel is off, we'll need it again Monday".

At this point I'm extremely irritated, that an alignment took four days, but I need it back and I won't leave it there over the weekend, so we pick it up. As I'm pulling into the garage, Nick suddenly gets very interested in the front bumper. Wouldn't you know it, the passenger side of the front bumper ground effects have a deep gouge that looks strikingly like someone didn't listen when I said the car was freshly painted and needed care taken, and whipped the car around the parking lot and through their steep easement, scraping it.

Now I'm pissed. $140 spent for a four day alignment, not only is it not done right, the car was damaged even after asking them to be careful with it.

Am I wrong about how bad the damage is, or blowing it out of proportion? It seems like something that will require a respray. They also put a deep scratch/gouge in the door handle, likely from the tech having the key in his hand when opening the door. So I'm going to see that every single time I use the car.

It has to go back Monday to get the steering straight, and this time I won't be leaving it. I'll be bringing up the door handle and bumper damage.
PXL_20220805_222507630.jpg
PXL_20220805_222755589.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
 #391664  by FIREM
 
Shops have insurance so push as hard as you can for repairs on their dime !!!!Get an estimate quote before returning if you can.
“No reason to treat a customers vehicle as your own or better than yours” (I’v seen what some of you drive) A quote from some guy trying to train new techs :roll:
Social Media can be devastating to a business, just choose your words carefully.
Curious as to how they corrected alignment. Did you get before and after print out (or did they forget/ printer out of ink or some other lame excuse. I know I’m “old school” but alignment after caster and camber are set is to Secure the steering wheel straight ahead and align toe to the wheel. Bet todays computer controlled / guided racks forgot to display that step in the screen.
Good luck Monday, don’t let this spoil your weekend.
FWIW I don’t think the “rust dust” is a big deal as long as there are no chunks. Probably surface dust from underside of strut tower and mount. Have seen this before, Obviously clean and monitor.
User avatar
 #391665  by First Lady
 
Sorry to see this Robert!! It’s definitely infuriating!!

We’ve run into the same thing many a time and have learned not to leave it if at all possible. If there’s even the slightest red flag in their service, pull the car out of there and go somewhere else. Its just not worth it! It’s very hard to find someone that cares about the car they are working on and actually take care of it.

I wish you all the luck on Monday but will be shocked if they do anything about it. Especially since you drove it away for the weekend. If your pics are time stamped that may help. If they do anything at all, they’re a better shop than I could have imagined but don’t ever go back!!
 #391687  by 00R/T
 
I DROVE IT!!!!

For the first time in two years, the special left my driveway. It was raining and I didn’t have headlights or wipers installed so I didn’t go far, but it was very exciting. I can’t adequately express my appreciation for our VP and a great friend. Without Ryan busting his butt this car would likely never have been on the road ever again.
User avatar
 #391688  by FIREM
 
Welcome back to the M world Steve !!
User avatar
 #391689  by LUNAT1C
 
Congrats Steve! I can imagine how exciting that feeling it. I was without my car for several months after the wreck and was over the moon when I could finally drive it again.

I'm sitting in the waiting room at the mechanic now while they finish the alignment, I literally just now heard the roar of the engine start and watched it pull away for the second road test today... I told them I need to leave by 11 to prepare for an important meeting. Also showed the damage to the woman who has been running the show here and I was friendly and courteous (I'm aware, she wants nothing to do with damaging a car than I do wanting a car damaged) and she asked me to get an estimate from my shop. Sent him some images.

Watching them move the car around, I know exactly how it happened. The alignment rack seems fine, however when I saw them pull the car in, they went way too fast in order to beat the oncoming traffic. I could see the fascia come within a centimeter of the concrete this morning. No doubt in my mind a little bit faster and it would bite the concrete easement.

If they can get the steering wheel straight and get it to track straight today (slightly pulled right on my way in today), and not put up a fuss with repairing the fascia, then I can let my anxiety go and move on. Planning next week to take some parts off the car to have hydrodipped in between shows and have ready for a show end of August. Have another show on Saturday that I attend every year, the Down on Main show on Main Street in Clawson, where the Clawson PD shut down their main street. I love it, and love the eclectic collection of cars that show up to this. Hoping another Model A comes so I can take a close look and ask the owner questions, haven't seen very many yet I saw two Maxwells a few years ago.
User avatar
 #391692  by First Lady
 
Great update Robert!! Best case I think here!
  • 1
  • 376
  • 377
  • 378
  • 379
  • 380