Chrysler 300M Enthusiasts Club
  • What did you do to your car today?

  • General Discussions about the 300M and other LHs
2023 Calendar Banner

Membership Banner

General Discussions about the 300M and other LHs

Moderator: Moderators

User avatar
 #392203  by FIREM
 
Added more miles to FIREM.
Quick trip to Easly/Greenville SC to visit friends for the weekend. 239000 and climbing. I absolutely LOVE driving this car!
monte4, sdugasjr liked this
 #392205  by TrepKing95
 
Gave the car a quick drive to clear the cobwebs from sitting while I deal with potty training the Jeep, hopefully I can start the transmission rebuild soon to fix the front pump seal leak that went from "slight seep" to "LEAK" (thinking of that insurance commercial "now THAT is a LEAK!") on the return from the MB meet.
User avatar
 #392206  by First Lady
 
Fenway (our puppy) and I were chauffeured to FL and back - both Keith and my M did a great job! Will give her a bath tomorrow to get the road grime off.
TrepKing95 liked this
User avatar
 #392239  by InfernoRedM
 
On a week away with the Special. I try to get to Elk county in Pennsylvania sometime in the fall. The elk were not too cooperative today, but here is a shot of the dirty Special at a wildlife viewing area. Fog is filling the valley below, which made viewing the elk more challenging as well. Couldn't help but take the photo!

Image
User avatar
 #392240  by InfernoRedM
 
Thought I'd share a couple of photos from last year when the elk were more cooperative. Enjoy!

Image

Image
monte4 liked this
User avatar
 #392242  by adu1982
 
Haven't been able to do any car work cause of my back. Just come out from the MRI, hoping for the best..... Even though it's been two weeks and hurts like a mofo...but anyways.

Did some "car work" today between work and going to the MRI. Put air in the tires on both the lhs and my base. Been driving the lhs to work and she is taking away, at over 246650 now .... The codes have not come up and the idle is almost as smooth as before the belt snapped. Started to think that what's left might cause by coils or fuel injectors as i though i smelled a bit of gas one morning when it was cooler..... But could have been from some other car too...
Sad that on such a nice weather i can't do any car work, any work at home or at work . Been relegated to office work at work which i hate and detest and i have yet to stay there a whole 8 hour and have just left early also since after a few hours the pain gets annoying..... Only laying on my back gets it better, sitting or walking is just as bad.

Sent from my motorola one 5G ace using Tapatalk

 #392249  by TrepKing95
 
After installing a backup camera in my Jeep with great success, I have ordered one for the 300M too! Should arrive tomorrow, but most likely won't get installed until Monday.
User avatar
 #392254  by monte4
 
Put the winter wheels and tires on last week (even though the M doesn't really see any winter, I have to have it ready just in case as my wife won't drive my 4x4 Ranger. She hates driving as she gets car sick so I do all the driving). Also clayed the paint and gave it a couple coats of sealant and did a fresh Mobil 1 oil change.
User avatar
 #392256  by Sneke_Eyez
 
TrepKing95 wrote: November 5th, 2022, 2:47 pm After installing a backup camera in my Jeep with great success, I have ordered one for the 300M too! Should arrive tomorrow, but most likely won't get installed until Monday.
Where and how? I was just remarking that this is the thing I want for my Special.
Problem is I don't want to give up my UConnect to do it.
User avatar
 #392258  by sdugasjr
 
Sneke_Eyez wrote: November 8th, 2022, 11:14 am
TrepKing95 wrote: November 5th, 2022, 2:47 pm After installing a backup camera in my Jeep with great success, I have ordered one for the 300M too! Should arrive tomorrow, but most likely won't get installed until Monday.
Where and how? I was just remarking that this is the thing I want for my Special.
Problem is I don't want to give up my UConnect to do it.
They make aftermarket rear view mirrors with dash cams/input for backup cameras prebuilt into them. Some even have Apple CarPlay/Android Auto support now, technology is crazy.
User avatar
 #392259  by LUNAT1C
 
Sneke_Eyez wrote: November 8th, 2022, 11:14 am Where and how? I was just remarking that this is the thing I want for my Special.
Problem is I don't want to give up my UConnect to do it.
Mike has an Xtrons unit based on Android, which I imagine has a B/U Cam input.
sdugasjr wrote: November 9th, 2022, 10:58 am They make aftermarket rear view mirrors with dash cams/input for backup cameras prebuilt into them. Some even have Apple CarPlay/Android Auto support now, technology is crazy.
Using one of those mirrors would kill uConnect, as the compatible microphone would be gone. It's not impossible, of course, as I've made a uConnect mirror work with my aftermarket radio for handsfree BT calling (only the microphone, not the call button), I'm sure if one of these mirrors has built-in microphones that could possibly be made to work with factory uConnect.
sdugasjr, Sneke_Eyez liked this
User avatar
 #392260  by Sneke_Eyez
 
Yes, my concern would be losing my UConnect capability.
User avatar
 #392261  by sdugasjr
 
Sneke_Eyez wrote: November 9th, 2022, 8:59 pm Yes, my concern would be losing my UConnect capability.
yeah I completely misread that, my apologies lol
 #392392  by TrepKing95
 
Sneke_Eyez wrote: November 9th, 2022, 8:59 pm Yes, my concern would be losing my UConnect capability.
When I finally made up my mind to install the XTRONS unit I thought I'd miss the factory Uconnect system, but Android Auto/Apple Carplay compatibility made up for it entirely. Might try and get the Uconnect Mirror buttons to work as additional inputs to the radio in the future if anything. I haven't decided where to mount the camera yet as the M doesn't have a lot of good places to put it. My Jeep Grand Cherokee (WJ Body) has a trim piece above the license plate and I was able to put the camera in it with a very slight offset to the right side. It didn't have as much of an effect on the usability of the camera as I'd expected. I might try something similar in the M; although the license plate "box" isn't as deep as I'd like, and is very low to the ground. I might rig it up to test viewing angle at that height.
Sneke_Eyez liked this
User avatar
 #392415  by FIREM
 
240,000 Mile service and prep for Holiday Travel ! Oil and Filter Change, Grease all greaseable suspension parts. Check and Inspect everything to avoid and travel disruptions.
Good wash and detail :shock:
Ready to go!!
TrepKing95 liked this
User avatar
 #392417  by LUNAT1C
 
Finally got around last night to fixing my sunroof wind deflector. The LH mount for the deflector broke while waiting in line during the Carlisle parade. I scavenged a replacement from a butane blue 04 a few months ago (got both sides while I was at it, just in case).

I think what made it break, and the part that broke was replaced several years ago, is the rivets were loose. I can't recall how tight they were when done last time, but I suspect the rivets I used (came with the Harbor Freight tool) were undersized, which allowed them to loosen over so many cycles of the glass.

Tried to replace it at Myrtle Beach, but this space requires a narrow nose rivet gun. So last night I drilled them out, and used 1/8" rivets that were longer. They were long enough that I had to push down against the headliner to seat them this time, so hopefully there is a tighter/wider grab now. Also dropped some washers on top to push the nose of the tool up out of the narrow space. Replacement mount is now installed and deflector back in, glass opening and closing normally and deflector popping up and dropping down normally again.

This is an ongoing issue. Bought the car in 09 with the RH side mount broken. Replaced the whole sunroof assembly, and found the new assembly had a broken LH mount. Drilled out my old assembly to replace it, and then that one broke this year. Hopefully this is the last time. I like opening the sunroof, but the buffeting at higher speeds is unbearable without that deflector.
First Lady, FIREM, Sneke_Eyez and 1 others liked this
User avatar
 #392429  by First Lady
 
Spent a bit of the afternoon replacing the AC compressor pulley and it looked like the bearing was leaking. A few members had listened to it at Myrtle Beach. Initial listening sounded fixed. Will keep an ear out.

Also started to pack the garage as there’s a move in the Jarvis household’s future. Stay tuned for more details!
LUNAT1C, TrepKing95 liked this
User avatar
 #392438  by In-trepid
 
I have a noisy AC compressor pulley. The clutch seems to work fine for now. It will be a spring job up north here in Illinois.
User avatar
 #392441  by M-Pressive
 
In-trepid wrote: December 12th, 2022, 4:38 pm I have a noisy AC compressor pulley. The clutch seems to work fine for now. It will be a spring job up north here in Illinois.
The clutch looked fine so we passed on replacing it.

Grab a band style oil filter remover for the job. Helps loosen the bolt and you need it to hold the front piece while torqueing it.
TrepKing95 liked this
User avatar
 #392443  by FIREM
 
First Lady wrote: December 11th, 2022, 9:53 pm Spent a bit of the afternoon replacing the AC compressor pulley and it looked like the bearing was leaking. A few members had listened to it at Myrtle Beach. Initial listening sounded fixed. Will keep an ear out.

Also started to pack the garage as there’s a move in the Jarvis household’s future. Stay tuned for more details!
May have been in limp mode but still workin LOL
Image
Sneke_Eyez, TrepKing95 liked this
  • 1
  • 378
  • 379
  • 380
  • 381
  • 382