Page 1 of 1

O2 sensor high voltage

PostPosted:August 28th, 2012, 5:55 pm
by LUNAT1C
A few years ago this code kept popping up (I forget the code now, I'll check it later tonight), that basically said O2 sensor 1 bank 2 high voltage. I fiddled with it, cleared the code... came back. Cleared it again, came back a few months later. I cleaned some dirt from the harness (pre-cat sensor, passenger side), cleared the code, and it stayed away until two Sundays ago. I had the code read by Advance and the guy said 99% chance it's not the sensor itself, rather something between it and the computer. Told me to bring to a shop in town (one he knows) to have the code read and diagnosed.

He said sensors don't go bad, which to me is complete bullcrap.

What are youse guys' thoughts? I honestly don't know what high voltage going to a sensor means, but something tells me I shouldn't be taking it to a random mechanic at the advice of an AAP counter person.

Re: O2 sensor high voltage

PostPosted:August 28th, 2012, 6:47 pm
by FIREM
Sensor Voltage High is most commonly caused by a poor ground.

Re: O2 sensor high voltage

PostPosted:September 5th, 2012, 5:52 am
by LUNAT1C
Finally remembered to key-dance out that code... I really should drive it more often.

Code is P0138... same one I had three years ago and fiddling with the connector cured.

O2 Oxygen Sensor Circuit High Voltage (Bank1, Sensor2)

Bob, any idea where that ground might be? I don't have an FSM handy and I'm terrible with complex electrical diagrams...

Re: O2 sensor high voltage

PostPosted:October 4th, 2022, 7:26 am
by Sneke_Eyez
I've been getting a random p0138 lately despite having changed the O2 sensors in early 2020, so it looks like I am going to go ground chasing this weekend.

Re: O2 sensor high voltage

PostPosted:October 4th, 2022, 1:08 pm
by TrepKing95
Sneke_Eyez wrote: October 4th, 2022, 7:26 am I've been getting a random p0138 lately despite having changed the O2 sensors in early 2020, so it looks like I am going to go ground chasing this weekend.
Looks like there is a TSB (08-031-02) for vehicles built prior to 4/18/2002 that flashes the PCM with updated software to address a laundry list of O2 sensor codes. Might be something to check at Carlisle 2023

Re: O2 sensor high voltage

PostPosted:October 4th, 2022, 2:42 pm
by FIREM
Interesting that there is a TSB. I have a reoccurring P0141 lately and swapping a known good sensor didn’t help.

Re: O2 sensor high voltage

PostPosted:October 5th, 2022, 9:09 am
by LUNAT1C
That would certainly impact me, but I haven't had any mystery O2 codes sincere I posted this. Only one from when a sensor harness was damaged.

Re: O2 sensor high voltage

PostPosted:October 18th, 2022, 6:00 pm
by Sneke_Eyez
Mine turned out to be a ground issue. My ground stud had loosened up for some reason, and while I started by checking my engine grounds, they were good, so I went to start checking my UConnect grounds, went to disconnect the battery and boom, there was the issue.

Re: O2 sensor high voltage

PostPosted:November 19th, 2022, 10:33 am
by Countachqv
I have had the B1S2 p138 as well on both of my cars I still hold (downstream driver), intermittently. It has occured to me to be a common issue as I also had it on other Ms I owned.
In one case I replaced the sensor and the issue went away.
In the other case I still have the sensor. This has gone on for 2 years now. I get it about 1 or 2 times a year for about 1 or 2 days. This seem to occur when I have not driven the car for over a week or when the weather is cold. Always at start up. Then driving the car makes it go away the next day or so. And always the B1S2 in all cases
If there is a flashing avail per TSB, how do we get it with out going to the dealer?

Re: O2 sensor high voltage

PostPosted:November 19th, 2022, 1:58 pm
by FIREM
I am still chasing random P0141 even after refreshing some grounds. Plan to "load test" harness and circuits back to PCM.
Chances of dealer being able to Flash out 20 year old cars, slim to none and likely to have at least an hours labor attached to it. For now I just carry a code reader and turn the light off.

Re: O2 sensor high voltage

PostPosted:December 7th, 2022, 12:07 pm
by FIREM
Finally Resolved this issue! All wiring checked and tested good. Grounds etc. and refreshed.
New Proper NTK Sensors still would throw code.
Scavenged some used sensors from the yard and voila a whole weeks worth of driving and NO Codes.
My guess is the used "seasoned" sensors were more "acceptable" to the TCM parameters than new ones.

Re: O2 sensor high voltage

PostPosted:December 8th, 2022, 5:08 pm
by Sneke_Eyez
My p0138 is back, much to my chagrin. I will check my grounds, but I will be at yards in VA this weekend and will be looking to see if I can pull a decent looking NTK sensor to see if that fixes the problem.

Re: O2 sensor high voltage

PostPosted:December 9th, 2022, 10:46 am
by FIREM
Just an FYI.
2002 downstream O2 sensor is the same as 01 and earlier upstream sensor (4606133ad)
Easier to access.
02 upstream is 4606555ad